met

QPTL Wrapper
met Namespace
See Also Example Hierarchy

Contains types of the QPTL .NET library intended for calculation of withholding taxes on payroll transactions of employers in the Canadian province of Quebec, which administers its own payroll taxes separately from the federal Canada Revenue Agency (CRA).

Classes

 | Class | Description
Public class | EmployeeDataQC | Contains employee data and results of calculation of payroll deductions.
Public class | QPTL | The main class of the QPTL .NET library, that allows to calculate withholding/deduction taxes on payroll transactions of employers in the Canadian province of Quebec.

Enumerations

 | Enumeration | Description
Public enumeration | CalculationType | Specifies a type of calculation.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Middle Earth Technologies Ltd.


CalculationType Enumeration

CalculationType Enumeration
See Also Example
[image]

Specifies a type of calculation.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Enum CalculationType
C#
public enum CalculationType
C++
public enum class CalculationType
J#
public enum CalculationType
JScript
public enum CalculationType

Members

Member Name | Description
Commission | Specifies the commission payments calculation.
RetroPay | Specifies the retroactive pay calculation.
Bonus | Specifies the bonus payments calculation.
Pension | Specifies the pension payments calculation.
RegularSalary | Specifies the regular salary/wages calculation.

See Also

met Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Middle Earth Technologies Ltd.

Generated from assembly QPTL32 [0.0.0.0]


EmployeeDataQC Class

EmployeeDataQC Class
See Also Example Members
[image]

Contains employee data and results of calculation of payroll deductions.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Class EmployeeDataQC
C#
public class EmployeeDataQC
C++
ref class EmployeeDataQC
J#
public class EmployeeDataQC
JScript
public class EmployeeDataQC

Remarks

NOTE: All monetary amounts represented by int data types are assumed to be in WHOLE CENTS. E.g. the monetary value of 4,382.16 is represented by 438216.

Inheritance Hierarchy

System.Object
met.EmployeeDataQC

See Also

EmployeeDataQC Members


EmployeeDataQC Members

EmployeeDataQC Members
See Also Example Constructors Fields Properties
[image]

Contains employee data and results of calculation of payroll deductions.

The following tables list the members exposed by EmployeeDataQC.

Public Constructors

 | Name | Description
Public method | EmployeeDataQC | Initializes a new instance of the EmployeeDataQC class with default values.
Top

Public Fields

Name | Description
Public field annualPayPeriods Number of annual pay periods:
Value | Description
240 or 260 | daily
52 or 53 | weekly
26 or 27 | bi-weekly
24 | semi-monthly
13 | every 4 weeks
12 | monthly
6 | bi-monthly
0 | commission income only
Public field | birthDate | Employee birthdate (optional). Format: YYYY-MM-DD. Default: a null reference (QPP age eligible).
Public field | bonusAmount | Current payroll bonus amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).
Public field | bonusDeductions | Current payroll taxable deductions related to bonus payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).
Public field | calcType | Obsolete. Calculation type (required). Possible values are defined in the CalculationType enum.
Public field | cntPP | Number of pay periods covered by current payroll. Default = 0.
Public field | commAmount | Current payroll commission pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Commission (calcType = 5).
Public field | daysSincePrevCommPmt | Number of days since the previous commission payment in the current payroll tax year. Is used only for CalculationType = CalculationType.Commission (calcType = 5).
Public field | dedCIP | Current pay period deduction respecting the CIP (Cooperative Investment Plan), that is, 125% of the amount withheld from the employee's remuneration for the purchase of preferred shares qualifying under the CIP.
Public field dedOther Current pay period portion of remuneration that gives entitlement to one of the following deductions:
  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.
Public field | dedQ | Current payroll deduction for amount withheld for the pay period for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ).
Public field | dedQ1 | Current payroll deduction for amount withheld for the pay period for the purchase of class A or class B shares in Fondaction, the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi.
Public field | dedQITD | Calculated Quebec Income Tax deduction (including Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQITD_YP | Calculated Quebec Income Tax deduction (excluding Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQITD_Z | Calculated Quebec Health contribution portion of income tax deduction amount (QITD). The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQPIP | Calculated Quebec Parental Insurance Program (QPIP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQPP | Calculated Quebec Pension Plan (QPP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedRCA | Amount withheld from current pay period for contribution to an RCA (retirement compensation arrangement).
Public field | dedRPP | Amount withheld from current pay period for contribution to an RPP.
Public field | dedRRSP | Amount withheld from current pay period for contribution to an RRSP.
Public field | dedSecurity | Current pay period security option deduction.
Public field | dedTravel | Current pay period travel deduction for residents of designated remote areas.
Public field | E | Quebec Claim Amount (from line 10 of the employeefs Quebec TP-1015.3-V form for the tax year in which the payroll is being paid.
Public field | employerQPIPcost | Calculated employer QPIP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.
Public field | employerQPPcost | Calculated employer QPP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.
Public field exemptQITD Exempt from Quebec income tax - total estimated income less than E.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec income tax
Public field exemptQITD_Z Exempt from Quebec Health contribution - requested by employee on TP-1015.3-V.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec Health contribution
Public field isQPIPexempt Quebec Parental Insurance Program (QPIP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPIP contributions.
Public field isQPPexempt Quebec Pension Plan (QPP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPP contributions.
Public field | J | Deductions indicated on line 19 of form TP-1015.3-V. Default = 0.
Public field | J1 | Annual taxable deductions authorized by Revenu Quebec after the employee completes and submits form TP-1016-V. Default = 0.
Public field | K1 | Non-refundable tax credits authorized by Revenu Quebec for the year after the employee completed form TP-1016-V (for example, the tax credit for charitable donations).
Public field | L | Employee-requested additional deduction of income tax (per pay period) – as requested by the individual on form TP--1017--V; or source deduction of income tax requested by a fisher on form TP-1015.N-V; or amount indicated on line 11 of form TP-1015.3-V, for the pay period. Default = 0.
Public field | payDate | Current payroll pay date (optional). Format: YYYY-MM-DD. Default: a null reference (current date).
Public field | payPeriod | Current pay period number (optional). Default = 0.
Public field | pensionAmount | Current payroll pension income amount, rounded to the nearest penny (e.g. 2,000.00 should be entered as 200000). Is used only for CalculationType = CalculationType.Pension (calcType = 2).
Public field | QPIP_Earnings | Calculated QPIP Insurable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.
Public field | QPP_Earnings | Calculated QPP Pensionable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.
Public field | retroDeductions | Current payroll taxable deductions related to retroactive pay payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | retroPayAmount | Current payroll retroactive pay amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | retroPayPeriods | Current payroll retroactive pay payroll periods – i.e. the number of payroll periods that the retroactive pay amount covers. Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | txCashBenefitsAmount | Current payroll taxable cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | txNonCashBenefitsAmount | Current payroll taxable non-cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | vacationPayAmount | Current payroll vacation pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | wagesAmount | Current payroll regular salary/wages amount, rounded to the nearest penny (e.g. 5,000.00 should be entered as 500000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | ytdBonus | Year-to-date prior cumulative bonuses paid (currently used only in bonus and commission income calculations (CalculationType = CalculationType.Bonus or CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdCIP | Year-to-date prior cumulative deduction respecting the CIP, that is, 125% of the amount withheld from the employee’s remuneration for the purchase of preferred shares qualifying under the CIP. Default = 0.
Public field | ytdComm | Year-to-date prior cumulative commissions paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdL | Year-to-date prior cumulative additional source deductions of income tax requested by the employee on form TP-1017-V, TP-1015.N-V, or TP-1015.3-V. Default = 0.
Public field ytdOther The portion of year-to-date prior cumulative remuneration that gives entitlement to one of the following deductions:
  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.
Default = 0;
Public field | ytdPension | Year-to-date prior cumulative pension income paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdQ | Year-to-date prior cumulative amounts withheld for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ). Default = 0.
Public field | ytdQ1 | Year-to-date prior cumulative amounts withheld for the purchase of class A or class B shares in the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi (called "Fondaction"). Default = 0.
Public field | ytdQITD | Year-to-date prior Quebec Income Tax employee payroll deductions. Default = 0.
Public field | ytdQITD_Z | Health contribution portion of year-to-date prior Quebec Income Tax employee payroll deductions (QITD). Default = 0.
Public field | ytdQPIP | Year-to-date prior Quebec Parental Insurance Program (QPIP) employee payroll deductions. Default = 0.
Public field | ytdQPIP_employer | Year-to-date prior Quebec Parental Insurance Program (QPIP) employer contributions. Default = 0.
Public field | ytdQPP | Year-to-date prior Quebec Pension Plan (QPP) employee payroll deductions. Default = 0.
Public field | ytdRCA | Year-to-date prior cumulative amounts withheld as contributions paid under a retirement compensation arrangement. Default = 0.
Public field | ytdRPP | Year-to-date prior cumulative amounts withheld as contributions to an RPP. Default = 0.
Public field | ytdRRSP | Year-to-date prior cumulative amounts withheld as contributions to an RRSP. Default = 0.
Public field | ytdSecurity | Year-to-date prior cumulative security option deduction. Default = 0.
Public field | ytdTravel | Year-to-date prior cumulative travel deduction for residents of designated remote areas. Default = 0.
Public field | ytdtxCashBenefitsAmount | Year-to-date prior cumulative taxable cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdtxNonCashBenefitsAmount | Year-to-date prior cumulative taxable non-cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdVacationPay | Year-to-date prior cumulative vacation pay paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdWages | Year-to-date prior cumulative salary and/or wages paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Top

Public Properties

 | Name | Description
Public property | CalculationType | Calculation type (required).
Top

See Also

EmployeeDataQC Class


EmployeeDataQC Constructor

EmployeeDataQC Constructor
[image]

Initializes a new instance of the EmployeeDataQC class with default values.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EmployeeDataQC()
C++
public:
EmployeeDataQC() sealed
J#
public EmployeeDataQC()
JScript
public function EmployeeDataQC()

See Also


Fields

EmployeeDataQC Fields
[image]

Public Fields

Name | Description
Public field annualPayPeriods Number of annual pay periods:
Value | Description
240 or 260 | daily
52 or 53 | weekly
26 or 27 | bi-weekly
24 | semi-monthly
13 | every 4 weeks
12 | monthly
6 | bi-monthly
0 | commission income only
Public field | birthDate | Employee birthdate (optional). Format: YYYY-MM-DD. Default: a null reference (QPP age eligible).
Public field | bonusAmount | Current payroll bonus amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).
Public field | bonusDeductions | Current payroll taxable deductions related to bonus payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).
Public field | calcType | Obsolete. Calculation type (required). Possible values are defined in the CalculationType enum.
Public field | cntPP | Number of pay periods covered by current payroll. Default = 0.
Public field | commAmount | Current payroll commission pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Commission (calcType = 5).
Public field | daysSincePrevCommPmt | Number of days since the previous commission payment in the current payroll tax year. Is used only for CalculationType = CalculationType.Commission (calcType = 5).
Public field | dedCIP | Current pay period deduction respecting the CIP (Cooperative Investment Plan), that is, 125% of the amount withheld from the employee's remuneration for the purchase of preferred shares qualifying under the CIP.
Public field dedOther Current pay period portion of remuneration that gives entitlement to one of the following deductions:
  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.
Public field | dedQ | Current payroll deduction for amount withheld for the pay period for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ).
Public field | dedQ1 | Current payroll deduction for amount withheld for the pay period for the purchase of class A or class B shares in Fondaction, the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi.
Public field | dedQITD | Calculated Quebec Income Tax deduction (including Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQITD_YP | Calculated Quebec Income Tax deduction (excluding Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQITD_Z | Calculated Quebec Health contribution portion of income tax deduction amount (QITD). The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQPIP | Calculated Quebec Parental Insurance Program (QPIP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedQPP | Calculated Quebec Pension Plan (QPP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.
Public field | dedRCA | Amount withheld from current pay period for contribution to an RCA (retirement compensation arrangement).
Public field | dedRPP | Amount withheld from current pay period for contribution to an RPP.
Public field | dedRRSP | Amount withheld from current pay period for contribution to an RRSP.
Public field | dedSecurity | Current pay period security option deduction.
Public field | dedTravel | Current pay period travel deduction for residents of designated remote areas.
Public field | E | Quebec Claim Amount (from line 10 of the employeefs Quebec TP-1015.3-V form for the tax year in which the payroll is being paid.
Public field | employerQPIPcost | Calculated employer QPIP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.
Public field | employerQPPcost | Calculated employer QPP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.
Public field exemptQITD Exempt from Quebec income tax - total estimated income less than E.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec income tax
Public field exemptQITD_Z Exempt from Quebec Health contribution - requested by employee on TP-1015.3-V.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec Health contribution
Public field isQPIPexempt Quebec Parental Insurance Program (QPIP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPIP contributions.
Public field isQPPexempt Quebec Pension Plan (QPP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPP contributions.
Public field | J | Deductions indicated on line 19 of form TP-1015.3-V. Default = 0.
Public field | J1 | Annual taxable deductions authorized by Revenu Quebec after the employee completes and submits form TP-1016-V. Default = 0.
Public field | K1 | Non-refundable tax credits authorized by Revenu Quebec for the year after the employee completed form TP-1016-V (for example, the tax credit for charitable donations).
Public field | L | Employee-requested additional deduction of income tax (per pay period) – as requested by the individual on form TP--1017--V; or source deduction of income tax requested by a fisher on form TP-1015.N-V; or amount indicated on line 11 of form TP-1015.3-V, for the pay period. Default = 0.
Public field | payDate | Current payroll pay date (optional). Format: YYYY-MM-DD. Default: a null reference (current date).
Public field | payPeriod | Current pay period number (optional). Default = 0.
Public field | pensionAmount | Current payroll pension income amount, rounded to the nearest penny (e.g. 2,000.00 should be entered as 200000). Is used only for CalculationType = CalculationType.Pension (calcType = 2).
Public field | QPIP_Earnings | Calculated QPIP Insurable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.
Public field | QPP_Earnings | Calculated QPP Pensionable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.
Public field | retroDeductions | Current payroll taxable deductions related to retroactive pay payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | retroPayAmount | Current payroll retroactive pay amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | retroPayPeriods | Current payroll retroactive pay payroll periods – i.e. the number of payroll periods that the retroactive pay amount covers. Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).
Public field | txCashBenefitsAmount | Current payroll taxable cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | txNonCashBenefitsAmount | Current payroll taxable non-cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | vacationPayAmount | Current payroll vacation pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | wagesAmount | Current payroll regular salary/wages amount, rounded to the nearest penny (e.g. 5,000.00 should be entered as 500000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).
Public field | ytdBonus | Year-to-date prior cumulative bonuses paid (currently used only in bonus and commission income calculations (CalculationType = CalculationType.Bonus or CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdCIP | Year-to-date prior cumulative deduction respecting the CIP, that is, 125% of the amount withheld from the employee’s remuneration for the purchase of preferred shares qualifying under the CIP. Default = 0.
Public field | ytdComm | Year-to-date prior cumulative commissions paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdL | Year-to-date prior cumulative additional source deductions of income tax requested by the employee on form TP-1017-V, TP-1015.N-V, or TP-1015.3-V. Default = 0.
Public field ytdOther The portion of year-to-date prior cumulative remuneration that gives entitlement to one of the following deductions:
  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.
Default = 0;
Public field | ytdPension | Year-to-date prior cumulative pension income paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdQ | Year-to-date prior cumulative amounts withheld for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ). Default = 0.
Public field | ytdQ1 | Year-to-date prior cumulative amounts withheld for the purchase of class A or class B shares in the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi (called "Fondaction"). Default = 0.
Public field | ytdQITD | Year-to-date prior Quebec Income Tax employee payroll deductions. Default = 0.
Public field | ytdQITD_Z | Health contribution portion of year-to-date prior Quebec Income Tax employee payroll deductions (QITD). Default = 0.
Public field | ytdQPIP | Year-to-date prior Quebec Parental Insurance Program (QPIP) employee payroll deductions. Default = 0.
Public field | ytdQPIP_employer | Year-to-date prior Quebec Parental Insurance Program (QPIP) employer contributions. Default = 0.
Public field | ytdQPP | Year-to-date prior Quebec Pension Plan (QPP) employee payroll deductions. Default = 0.
Public field | ytdRCA | Year-to-date prior cumulative amounts withheld as contributions paid under a retirement compensation arrangement. Default = 0.
Public field | ytdRPP | Year-to-date prior cumulative amounts withheld as contributions to an RPP. Default = 0.
Public field | ytdRRSP | Year-to-date prior cumulative amounts withheld as contributions to an RRSP. Default = 0.
Public field | ytdSecurity | Year-to-date prior cumulative security option deduction. Default = 0.
Public field | ytdTravel | Year-to-date prior cumulative travel deduction for residents of designated remote areas. Default = 0.
Public field | ytdtxCashBenefitsAmount | Year-to-date prior cumulative taxable cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdtxNonCashBenefitsAmount | Year-to-date prior cumulative taxable non-cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdVacationPay | Year-to-date prior cumulative vacation pay paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Public field | ytdWages | Year-to-date prior cumulative salary and/or wages paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.
Top

See Also


annualPayPeriods Field

EmployeeDataQC.annualPayPeriods Field
[image]

Number of annual pay periods:
Value | Description
240 or 260 | daily
52 or 53 | weekly
26 or 27 | bi-weekly
24 | semi-monthly
13 | every 4 weeks
12 | monthly
6 | bi-monthly
0 | commission income only

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public annualPayPeriods As UInt16
C#
public ushort annualPayPeriods;
C++
public:
unsigned short annualPayPeriods sealed ;
J#
public ushort annualPayPeriods
JScript
public annualPayPeriods : UInt16;

See Also


birthDate Field

EmployeeDataQC.birthDate Field
[image]

Employee birthdate (optional). Format: YYYY-MM-DD. Default: a null reference (QPP age eligible).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public birthDate As String
C#
public string birthDate;
C++
public:
String birthDate sealed ;
J#
public string birthDate
JScript
public birthDate : String;

Remarks

Is used for determining QPP age eligility only. If is a null reference, the employee is assumed to be age eligible for QPP deductions.

See Also


bonusAmount Field

EmployeeDataQC.bonusAmount Field
[image]

Current payroll bonus amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public bonusAmount As Integer
C#
public int bonusAmount;
C++
public:
int bonusAmount sealed ;
J#
public int bonusAmount
JScript
public bonusAmount : int;

See Also


bonusDeductions Field

EmployeeDataQC.bonusDeductions Field
[image]

Current payroll taxable deductions related to bonus payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Bonus (calcType = 3).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public bonusDeductions As Integer
C#
public int bonusDeductions;
C++
public:
int bonusDeductions sealed ;
J#
public int bonusDeductions
JScript
public bonusDeductions : int;

See Also


calcType Field

EmployeeDataQC.calcType Field
[image]

NOTE: This field is now obsolete.

Use the CalculationType property instead.

Calculation type (required). Possible values are defined in the CalculationType enum.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public calcType As UInt16
C#
public ushort calcType;
C++
public:
unsigned short calcType sealed ;
J#
public ushort calcType
JScript
public calcType : UInt16;

Remarks

You must cast a value of the CalculationType enum to ushort before assigning to this field. Use the CalculationType property to access the field without cast.

See Also


cntPP Field

EmployeeDataQC.cntPP Field
[image]

Number of pay periods covered by current payroll. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public cntPP As UInt16
C#
public ushort cntPP;
C++
public:
unsigned short cntPP sealed ;
J#
public ushort cntPP
JScript
public cntPP : UInt16;

Remarks

Valid values range from 0 to annualPayPeriods - payPeriod + 1.

If the current payroll calculation is for more than one (1) payroll period, specify the number of periods in this field. A value of 0 (default) or 1 in this field will be treated as the default value of one pay period for a payroll calculation.

See Also


commAmount Field

EmployeeDataQC.commAmount Field
[image]

Current payroll commission pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.Commission (calcType = 5).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public commAmount As Integer
C#
public int commAmount;
C++
public:
int commAmount sealed ;
J#
public int commAmount
JScript
public commAmount : int;

See Also


daysSincePrevCommPmt Field

EmployeeDataQC.daysSincePrevCommPmt Field
[image]

Number of days since the previous commission payment in the current payroll tax year. Is used only for CalculationType = CalculationType.Commission (calcType = 5).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public daysSincePrevCommPmt As UInt16
C#
public ushort daysSincePrevCommPmt;
C++
public:
unsigned short daysSincePrevCommPmt sealed ;
J#
public ushort daysSincePrevCommPmt
JScript
public daysSincePrevCommPmt : UInt16;

Remarks

Valid values range from 0-365.

See Also


dedCIP Field

EmployeeDataQC.dedCIP Field
[image]

Current pay period deduction respecting the CIP (Cooperative Investment Plan), that is, 125% of the amount withheld from the employee's remuneration for the purchase of preferred shares qualifying under the CIP.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedCIP As Integer
C#
public int dedCIP;
C++
public:
int dedCIP sealed ;
J#
public int dedCIP
JScript
public dedCIP : int;

See Also


dedOther Field

EmployeeDataQC.dedOther Field
[image]

Current pay period portion of remuneration that gives entitlement to one of the following deductions:

  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedOther As Integer
C#
public int dedOther;
C++
public:
int dedOther sealed ;
J#
public int dedOther
JScript
public dedOther : int;

See Also


dedQ Field

EmployeeDataQC.dedQ Field
[image]

Current payroll deduction for amount withheld for the pay period for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQ As Integer
C#
public int dedQ;
C++
public:
int dedQ sealed ;
J#
public int dedQ
JScript
public dedQ : int;

See Also


dedQ1 Field

EmployeeDataQC.dedQ1 Field
[image]

Current payroll deduction for amount withheld for the pay period for the purchase of class A or class B shares in Fondaction, the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQ1 As Integer
C#
public int dedQ1;
C++
public:
int dedQ1 sealed ;
J#
public int dedQ1
JScript
public dedQ1 : int;

See Also


dedQITD Field

EmployeeDataQC.dedQITD Field
[image]

Calculated Quebec Income Tax deduction (including Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQITD As Integer
C#
public int dedQITD;
C++
public:
int dedQITD sealed ;
J#
public int dedQITD
JScript
public dedQITD : int;

See Also


dedQITD_YP Field

EmployeeDataQC.dedQITD_YP Field
[image]

Calculated Quebec Income Tax deduction (excluding Requested Additional Deduction) for current payroll. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQITD_YP As Integer
C#
public int dedQITD_YP;
C++
public:
int dedQITD_YP sealed ;
J#
public int dedQITD_YP
JScript
public dedQITD_YP : int;

See Also


dedQITD_Z Field

EmployeeDataQC.dedQITD_Z Field
[image]

Calculated Quebec Health contribution portion of income tax deduction amount (QITD). The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQITD_Z As Integer
C#
public int dedQITD_Z;
C++
public:
int dedQITD_Z sealed ;
J#
public int dedQITD_Z
JScript
public dedQITD_Z : int;

See Also


dedQPIP Field

EmployeeDataQC.dedQPIP Field
[image]

Calculated Quebec Parental Insurance Program (QPIP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQPIP As Integer
C#
public int dedQPIP;
C++
public:
int dedQPIP sealed ;
J#
public int dedQPIP
JScript
public dedQPIP : int;

See Also


dedQPP Field

EmployeeDataQC.dedQPP Field
[image]

Calculated Quebec Pension Plan (QPP) deduction for current payroll. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedQPP As Integer
C#
public int dedQPP;
C++
public:
int dedQPP sealed ;
J#
public int dedQPP
JScript
public dedQPP : int;

See Also


dedRCA Field

EmployeeDataQC.dedRCA Field
[image]

Amount withheld from current pay period for contribution to an RCA (retirement compensation arrangement).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedRCA As Integer
C#
public int dedRCA;
C++
public:
int dedRCA sealed ;
J#
public int dedRCA
JScript
public dedRCA : int;

See Also


dedRPP Field

EmployeeDataQC.dedRPP Field
[image]

Amount withheld from current pay period for contribution to an RPP.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedRPP As Integer
C#
public int dedRPP;
C++
public:
int dedRPP sealed ;
J#
public int dedRPP
JScript
public dedRPP : int;

See Also


dedRRSP Field

EmployeeDataQC.dedRRSP Field
[image]

Amount withheld from current pay period for contribution to an RRSP.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedRRSP As Integer
C#
public int dedRRSP;
C++
public:
int dedRRSP sealed ;
J#
public int dedRRSP
JScript
public dedRRSP : int;

See Also


dedSecurity Field

EmployeeDataQC.dedSecurity Field
[image]

Current pay period security option deduction.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedSecurity As Integer
C#
public int dedSecurity;
C++
public:
int dedSecurity sealed ;
J#
public int dedSecurity
JScript
public dedSecurity : int;

See Also


dedTravel Field

EmployeeDataQC.dedTravel Field
[image]

Current pay period travel deduction for residents of designated remote areas.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public dedTravel As Integer
C#
public int dedTravel;
C++
public:
int dedTravel sealed ;
J#
public int dedTravel
JScript
public dedTravel : int;

See Also


E Field

EmployeeDataQC.E Field
[image]

Quebec Claim Amount (from line 10 of the employeefs Quebec TP-1015.3-V form for the tax year in which the payroll is being paid.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public E As Integer
C#
public int E;
C++
public:
int E sealed ;
J#
public int E
JScript
public E : int;

Remarks

If no Quebec TP-1015.3-V form is available for the employee, then the default Basic Claim amount can be claimed by setting this value = 1.

NOTE: TP-1015.3-V Claim Codes cannot be used instead of Claim Amounts – Claim Amounts less than the Basic Claim Amount (except Claim Amount = 0) for the applicable tax year will be automatically adjusted up to the minimum Basic Claim Amount for the year for all payroll tax deduction calculations. Claim Amount = 0 will be treated as a Nil claim amount.

See Also


employerQPIPcost Field

EmployeeDataQC.employerQPIPcost Field
[image]

Calculated employer QPIP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public employerQPIPcost As Integer
C#
public int employerQPIPcost;
C++
public:
int employerQPIPcost sealed ;
J#
public int employerQPIPcost
JScript
public employerQPIPcost : int;

See Also


employerQPPcost Field

EmployeeDataQC.employerQPPcost Field
[image]

Calculated employer QPP contribution (cost) for the current payroll calculation. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public employerQPPcost As Integer
C#
public int employerQPPcost;
C++
public:
int employerQPPcost sealed ;
J#
public int employerQPPcost
JScript
public employerQPPcost : int;

See Also


exemptQITD Field

EmployeeDataQC.exemptQITD Field
[image]

Exempt from Quebec income tax - total estimated income less than E.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec income tax

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public exemptQITD As UInt16
C#
public ushort exemptQITD;
C++
public:
unsigned short exemptQITD sealed ;
J#
public ushort exemptQITD
JScript
public exemptQITD : UInt16;

Remarks

The employee must enter “X” on line 20 of the Quebec TP-1015.3-V form to be able to claim an exemption from Quebec income tax deductions. The employee can claim this exemption if he or she estimates that his or her total income from all sources for the year will be less than the total of the following amounts:

  • The amount entered on line 10 of the form, multiplied by 1.25;
  • The amount entered on line 19 of the form.

See Also


exemptQITD_Z Field

EmployeeDataQC.exemptQITD_Z Field
[image]

Exempt from Quebec Health contribution - requested by employee on TP-1015.3-V.
Value | Description
0 (default) | No exemption
1 | Exempt from Quebec Health contribution

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public exemptQITD_Z As UInt16
C#
public ushort exemptQITD_Z;
C++
public:
unsigned short exemptQITD_Z sealed ;
J#
public ushort exemptQITD_Z
JScript
public exemptQITD_Z : UInt16;

Remarks

The employee must check the box on line 22 of the Quebec TP-1015.3-V form to be able to claim an exemption from Quebec health contribution, which is included in the calculated amount of Quebec income tax to be deducted. The employee can claim this exemption if in one of the following situations:

  • Will not be a resident of Quebec at end of year;
  • Another employer already withholds employee’s health contribution;
  • Employee is required to make instalment payments;
  • Employee’s net income (line 275 of the income tax return), plus that of employee’s spouse, if applicable, is less than or equal to the exemption threshold applicable to the employee’s family situation (see table on form TP-1015.3-V).

See Also


isQPIPexempt Field

EmployeeDataQC.isQPIPexempt Field
[image]

Quebec Parental Insurance Program (QPIP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPIP contributions.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public isQPIPexempt As UInt16
C#
public ushort isQPIPexempt;
C++
public:
unsigned short isQPIPexempt sealed ;
J#
public ushort isQPIPexempt
JScript
public isQPIPexempt : UInt16;

Remarks

Note: for future use only - no exemptions currently exist.

See Also


isQPPexempt Field

EmployeeDataQC.isQPPexempt Field
[image]

Quebec Pension Plan (QPP) exempt indicator.
Value | Description
0 (default) | No exemption
1 | Exempt from QPP contributions.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public isQPPexempt As UInt16
C#
public ushort isQPPexempt;
C++
public:
unsigned short isQPPexempt sealed ;
J#
public ushort isQPPexempt
JScript
public isQPPexempt : UInt16;

See Also


J Field

EmployeeDataQC.J Field
[image]

Deductions indicated on line 19 of form TP-1015.3-V. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public J As Integer
C#
public int J;
C++
public:
int J sealed ;
J#
public int J
JScript
public J : int;

See Also


J1 Field

EmployeeDataQC.J1 Field
[image]

Annual taxable deductions authorized by Revenu Quebec after the employee completes and submits form TP-1016-V. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public J1 As Integer
C#
public int J1;
C++
public:
int J1 sealed ;
J#
public int J1
JScript
public J1 : int;

Remarks

The employee must provide the employer with a copy of the letter from Revenu Quebec authorizing the taxable deduction amount, and the copy of the letter must be kept in the employee's payroll file for audit purposes.

See Also


K1 Field

EmployeeDataQC.K1 Field
[image]

Non-refundable tax credits authorized by Revenu Quebec for the year after the employee completed form TP-1016-V (for example, the tax credit for charitable donations).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public K1 As Integer
C#
public int K1;
C++
public:
int K1 sealed ;
J#
public int K1
JScript
public K1 : int;

See Also


L Field

EmployeeDataQC.L Field
[image]

Employee-requested additional deduction of income tax (per pay period) – as requested by the individual on form TP--1017--V; or source deduction of income tax requested by a fisher on form TP-1015.N-V; or amount indicated on line 11 of form TP-1015.3-V, for the pay period. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public L As Integer
C#
public int L;
C++
public:
int L sealed ;
J#
public int L
JScript
public L : int;

See Also


payDate Field

EmployeeDataQC.payDate Field
[image]

Current payroll pay date (optional). Format: YYYY-MM-DD. Default: a null reference (current date).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public payDate As String
C#
public string payDate;
C++
public:
String payDate sealed ;
J#
public string payDate
JScript
public payDate : String;

Remarks

The payroll pay date is used to determine the appropriate QPTL library to use for payroll calculations. The date should not be before the Effective Date (QPTL.getEffDate()) or after the Tax Year (QPTL.getTaxYear()) of the library. If the value is a null reference or an empty string, then the current system date will be used as the pay date.

NOTE: please ensure that previous tax year QPTL DLL files are installed and available somewhere in the system search path at runtime.

See Also


payPeriod Field

EmployeeDataQC.payPeriod Field
[image]

Current pay period number (optional). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public payPeriod As UInt16
C#
public ushort payPeriod;
C++
public:
unsigned short payPeriod sealed ;
J#
public ushort payPeriod
JScript
public payPeriod : UInt16;

Remarks

Valid values range from 0 to the annualPayPeriods value.

If the current pay period number is provided (i.e. value > 0), then the calculation of the income tax deduction for some payroll calculation types will use the value of year-to-date income tax deductions (see ytdQITD) to adjust the calculation of current pay period income tax deductions.

See Also


pensionAmount Field

EmployeeDataQC.pensionAmount Field
[image]

Current payroll pension income amount, rounded to the nearest penny (e.g. 2,000.00 should be entered as 200000). Is used only for CalculationType = CalculationType.Pension (calcType = 2).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public pensionAmount As Integer
C#
public int pensionAmount;
C++
public:
int pensionAmount sealed ;
J#
public int pensionAmount
JScript
public pensionAmount : int;

See Also


QPIP_Earnings Field

EmployeeDataQC.QPIP_Earnings Field
[image]

Calculated QPIP Insurable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public QPIP_Earnings As Integer
C#
public int QPIP_Earnings;
C++
public:
int QPIP_Earnings sealed ;
J#
public int QPIP_Earnings
JScript
public QPIP_Earnings : int;

See Also


QPP_Earnings Field

EmployeeDataQC.QPP_Earnings Field
[image]

Calculated QPP Pensionable Earnings amount. The field is filled by the QPTL.calcDeductions(..) method.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public QPP_Earnings As Integer
C#
public int QPP_Earnings;
C++
public:
int QPP_Earnings sealed ;
J#
public int QPP_Earnings
JScript
public QPP_Earnings : int;

See Also


retroDeductions Field

EmployeeDataQC.retroDeductions Field
[image]

Current payroll taxable deductions related to retroactive pay payment, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public retroDeductions As Integer
C#
public int retroDeductions;
C++
public:
int retroDeductions sealed ;
J#
public int retroDeductions
JScript
public retroDeductions : int;

See Also


retroPayAmount Field

EmployeeDataQC.retroPayAmount Field
[image]

Current payroll retroactive pay amount, rounded to the nearest penny (e.g. 1,000.00 should be entered as 100000). Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public retroPayAmount As Integer
C#
public int retroPayAmount;
C++
public:
int retroPayAmount sealed ;
J#
public int retroPayAmount
JScript
public retroPayAmount : int;

See Also


retroPayPeriods Field

EmployeeDataQC.retroPayPeriods Field
[image]

Current payroll retroactive pay payroll periods – i.e. the number of payroll periods that the retroactive pay amount covers. Is used only for CalculationType = CalculationType.RetroPay (calcType = 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public retroPayPeriods As UInt16
C#
public ushort retroPayPeriods;
C++
public:
unsigned short retroPayPeriods sealed ;
J#
public ushort retroPayPeriods
JScript
public retroPayPeriods : UInt16;

Remarks

Valid values range from 1 to the annualPayPeriods field value.

See Also


txCashBenefitsAmount Field

EmployeeDataQC.txCashBenefitsAmount Field
[image]

Current payroll taxable cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public txCashBenefitsAmount As Integer
C#
public int txCashBenefitsAmount;
C++
public:
int txCashBenefitsAmount sealed ;
J#
public int txCashBenefitsAmount
JScript
public txCashBenefitsAmount : int;

See Also


txNonCashBenefitsAmount Field

EmployeeDataQC.txNonCashBenefitsAmount Field
[image]

Current payroll taxable non-cash benefits amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public txNonCashBenefitsAmount As Integer
C#
public int txNonCashBenefitsAmount;
C++
public:
int txNonCashBenefitsAmount sealed ;
J#
public int txNonCashBenefitsAmount
JScript
public txNonCashBenefitsAmount : int;

See Also


vacationPayAmount Field

EmployeeDataQC.vacationPayAmount Field
[image]

Current payroll vacation pay amount, rounded to the nearest penny (e.g. 100.00 should be entered as 10000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public vacationPayAmount As Integer
C#
public int vacationPayAmount;
C++
public:
int vacationPayAmount sealed ;
J#
public int vacationPayAmount
JScript
public vacationPayAmount : int;

See Also


wagesAmount Field

EmployeeDataQC.wagesAmount Field
[image]

Current payroll regular salary/wages amount, rounded to the nearest penny (e.g. 5,000.00 should be entered as 500000). Is used for CalculationType = CalculationType.RegularSalary, CalculationType.Bonus and CalculationType.RetroPay (calcType = 1, 3 and 4).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public wagesAmount As Integer
C#
public int wagesAmount;
C++
public:
int wagesAmount sealed ;
J#
public int wagesAmount
JScript
public wagesAmount : int;

See Also


ytdBonus Field

EmployeeDataQC.ytdBonus Field
[image]

Year-to-date prior cumulative bonuses paid (currently used only in bonus and commission income calculations (CalculationType = CalculationType.Bonus or CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdBonus As Integer
C#
public int ytdBonus;
C++
public:
int ytdBonus sealed ;
J#
public int ytdBonus
JScript
public ytdBonus : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdCIP Field

EmployeeDataQC.ytdCIP Field
[image]

Year-to-date prior cumulative deduction respecting the CIP, that is, 125% of the amount withheld from the employee’s remuneration for the purchase of preferred shares qualifying under the CIP. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdCIP As Integer
C#
public int ytdCIP;
C++
public:
int ytdCIP sealed ;
J#
public int ytdCIP
JScript
public ytdCIP : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdComm Field

EmployeeDataQC.ytdComm Field
[image]

Year-to-date prior cumulative commissions paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdComm As Integer
C#
public int ytdComm;
C++
public:
int ytdComm sealed ;
J#
public int ytdComm
JScript
public ytdComm : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdL Field

EmployeeDataQC.ytdL Field
[image]

Year-to-date prior cumulative additional source deductions of income tax requested by the employee on form TP-1017-V, TP-1015.N-V, or TP-1015.3-V. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdL As Integer
C#
public int ytdL;
C++
public:
int ytdL sealed ;
J#
public int ytdL
JScript
public ytdL : int;

Remarks

NOTE: the year-to-date total does NOT include the amount included in the current payroll deduction for Quebec income taxes. The year-to-date amount is used in calculating the current pay period income tax deduction for some types of payroll payments. See payPeriod.

See Also


ytdOther Field

EmployeeDataQC.ytdOther Field
[image]

The portion of year-to-date prior cumulative remuneration that gives entitlement to one of the following deductions:

  • The deduction for employment income situated on a reserve or premises,
  • The deduction for employment income earned on a vessel,
  • The deduction for employees of an international financial centre (IFC),
  • The deduction for foreign specialists, foreign researchers, foreign researchers on a post-doctoral internship, foreign experts, foreign professors, foreign producers, foreign individuals holding a key position in a foreign production filmed in Quebec, foreign farm workers, members of the Canadian forces or members of a Canadian police force.
Default = 0;

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdOther As Integer
C#
public int ytdOther;
C++
public:
int ytdOther sealed ;
J#
public int ytdOther
JScript
public ytdOther : int;

Remarks

NOTE: the year-to-date total does NOT include any amount included in the current payroll period calculation.

See Also


ytdPension Field

EmployeeDataQC.ytdPension Field
[image]

Year-to-date prior cumulative pension income paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdPension As Integer
C#
public int ytdPension;
C++
public:
int ytdPension sealed ;
J#
public int ytdPension
JScript
public ytdPension : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdQ Field

EmployeeDataQC.ytdQ Field
[image]

Year-to-date prior cumulative amounts withheld for the purchase of class A shares in the Fonds de solidarite des travailleurs du Quebec (FTQ). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQ As Integer
C#
public int ytdQ;
C++
public:
int ytdQ sealed ;
J#
public int ytdQ
JScript
public ytdQ : int;

Remarks

NOTE: the year-to-date total does NOT include the amount deducted in the current payroll calculation.

See Also


ytdQ1 Field

EmployeeDataQC.ytdQ1 Field
[image]

Year-to-date prior cumulative amounts withheld for the purchase of class A or class B shares in the Fonds de developpement de la Confederation des syndicates nationaux pour la cooperation et l'emploi (called "Fondaction"). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQ1 As Integer
C#
public int ytdQ1;
C++
public:
int ytdQ1 sealed ;
J#
public int ytdQ1
JScript
public ytdQ1 : int;

Remarks

NOTE: the year-to-date total does NOT include the amount deducted in the current payroll calculation.

See Also


ytdQITD Field

EmployeeDataQC.ytdQITD Field
[image]

Year-to-date prior Quebec Income Tax employee payroll deductions. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQITD As Integer
C#
public int ytdQITD;
C++
public:
int ytdQITD sealed ;
J#
public int ytdQITD
JScript
public ytdQITD : int;

Remarks

NOTE: the year-to-date total does NOT include the current payroll deduction for Quebec income taxes. There is no maximum annual deduction for Quebec income taxes, however the year-to-date amount can be optionally used in calculating the current pay period income tax deduction for some types of payroll payments. See payPeriod.

See Also


ytdQITD_Z Field

EmployeeDataQC.ytdQITD_Z Field
[image]

Health contribution portion of year-to-date prior Quebec Income Tax employee payroll deductions (QITD). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQITD_Z As Integer
C#
public int ytdQITD_Z;
C++
public:
int ytdQITD_Z sealed ;
J#
public int ytdQITD_Z
JScript
public ytdQITD_Z : int;

Remarks

NOTE: the year-to-date total does NOT include the amount included in the current payroll deduction for Quebec income taxes. The year-to-date amount is used in calculating the current pay period income tax deduction for some types of payroll payments. See payPeriod.

See Also


ytdQPIP Field

EmployeeDataQC.ytdQPIP Field
[image]

Year-to-date prior Quebec Parental Insurance Program (QPIP) employee payroll deductions. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQPIP As Integer
C#
public int ytdQPIP;
C++
public:
int ytdQPIP sealed ;
J#
public int ytdQPIP
JScript
public ytdQPIP : int;

Remarks

NOTE: the year-to-date total does NOT include the current payroll deduction for QPIP. The year-to-date amount is used to determine when the employee has reached the maximum annual deduction for QPIP and adjust the calculation of current QPIP deduction accordingly.

See Also


ytdQPIP_employer Field

EmployeeDataQC.ytdQPIP_employer Field
[image]

Year-to-date prior Quebec Parental Insurance Program (QPIP) employer contributions. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQPIP_employer As Integer
C#
public int ytdQPIP_employer;
C++
public:
int ytdQPIP_employer sealed ;
J#
public int ytdQPIP_employer
JScript
public ytdQPIP_employer : int;

Remarks

NOTE: the year-to-date total does NOT include the current employer contribution for QPIP. The year-to-date amount is used to determine when the employer has reached the maximum annual contribution for QPIP and adjust the calculation of current QPIP employer contribution accordingly.

See Also


ytdQPP Field

EmployeeDataQC.ytdQPP Field
[image]

Year-to-date prior Quebec Pension Plan (QPP) employee payroll deductions. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdQPP As Integer
C#
public int ytdQPP;
C++
public:
int ytdQPP sealed ;
J#
public int ytdQPP
JScript
public ytdQPP : int;

Remarks

NOTE: the year-to-date total does NOT include the current payroll deduction for QPP. The year-to-date amount is used to determine when the employee has reached the maximum annual deduction for QPP and adjust the calculation of current QPP deduction accordingly.

See Also


ytdRCA Field

EmployeeDataQC.ytdRCA Field
[image]

Year-to-date prior cumulative amounts withheld as contributions paid under a retirement compensation arrangement. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdRCA As Integer
C#
public int ytdRCA;
C++
public:
int ytdRCA sealed ;
J#
public int ytdRCA
JScript
public ytdRCA : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdRPP Field

EmployeeDataQC.ytdRPP Field
[image]

Year-to-date prior cumulative amounts withheld as contributions to an RPP. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdRPP As Integer
C#
public int ytdRPP;
C++
public:
int ytdRPP sealed ;
J#
public int ytdRPP
JScript
public ytdRPP : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdRRSP Field

EmployeeDataQC.ytdRRSP Field
[image]

Year-to-date prior cumulative amounts withheld as contributions to an RRSP. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdRRSP As Integer
C#
public int ytdRRSP;
C++
public:
int ytdRRSP sealed ;
J#
public int ytdRRSP
JScript
public ytdRRSP : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdSecurity Field

EmployeeDataQC.ytdSecurity Field
[image]

Year-to-date prior cumulative security option deduction. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdSecurity As Integer
C#
public int ytdSecurity;
C++
public:
int ytdSecurity sealed ;
J#
public int ytdSecurity
JScript
public ytdSecurity : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdTravel Field

EmployeeDataQC.ytdTravel Field
[image]

Year-to-date prior cumulative travel deduction for residents of designated remote areas. Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdTravel As Integer
C#
public int ytdTravel;
C++
public:
int ytdTravel sealed ;
J#
public int ytdTravel
JScript
public ytdTravel : int;

Remarks

NOTE: the year-to-date total does NOT include any amount being deducted in the current payroll calculation.

See Also


ytdtxCashBenefitsAmount Field

EmployeeDataQC.ytdtxCashBenefitsAmount Field
[image]

Year-to-date prior cumulative taxable cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdtxCashBenefitsAmount As Integer
C#
public int ytdtxCashBenefitsAmount;
C++
public:
int ytdtxCashBenefitsAmount sealed ;
J#
public int ytdtxCashBenefitsAmount
JScript
public ytdtxCashBenefitsAmount : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdtxNonCashBenefitsAmount Field

EmployeeDataQC.ytdtxNonCashBenefitsAmount Field
[image]

Year-to-date prior cumulative taxable non-cash benefits paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdtxNonCashBenefitsAmount As Integer
C#
public int ytdtxNonCashBenefitsAmount;
C++
public:
int ytdtxNonCashBenefitsAmount sealed ;
J#
public int ytdtxNonCashBenefitsAmount
JScript
public ytdtxNonCashBenefitsAmount : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdVacationPay Field

EmployeeDataQC.ytdVacationPay Field
[image]

Year-to-date prior cumulative vacation pay paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdVacationPay As Integer
C#
public int ytdVacationPay;
C++
public:
int ytdVacationPay sealed ;
J#
public int ytdVacationPay
JScript
public ytdVacationPay : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


ytdWages Field

EmployeeDataQC.ytdWages Field
[image]

Year-to-date prior cumulative salary and/or wages paid (currently used only in commission income calculations (CalculationType = CalculationType.Commission)). Default = 0.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public ytdWages As Integer
C#
public int ytdWages;
C++
public:
int ytdWages sealed ;
J#
public int ytdWages
JScript
public ytdWages : int;

Remarks

NOTE: the year-to-date total is PRIOR to the current pay period payment amount – i.e. it does NOT include the current payroll payment.

See Also


Properties

EmployeeDataQC Properties
[image]

Public Properties

 | Name | Description
Public property | CalculationType | Calculation type (required).
Top

See Also


CalculationType Property

EmployeeDataQC.CalculationType Property
[image]

Calculation type (required).

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Property CalculationType As CalculationType
C#
public CalculationType CalculationType { get; set; }
C++
public property CalculationType CalculationType sealed {
CalculationType get();
void set(CalculationType value);
}
J#
/** property */
public CalculationType get_CalculationType();

/** property */
public void set_CalculationType(CalculationType value);
JScript
public function get CalculationType() : CalculationType

public function set CalculationType(value : CalculationType);

See Also


QPTL Class

QPTL Class
See Also Example Members
[image]

The main class of the QPTL .NET library, that allows to calculate withholding/deduction taxes on payroll transactions of employers in the Canadian province of Quebec.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Class QPTL
C#
public class QPTL
C++
ref class QPTL
J#
public class QPTL
JScript
public class QPTL

Remarks

NOTE: All monetary amounts represented by int data types are assumed to be in WHOLE CENTS. E.g. the monetary value of 4,382.16 is represented by 438216.

Inheritance Hierarchy

System.Object
met.QPTL

See Also

QPTL Members


QPTL Members

QPTL Members
See Also Example Constructors Methods
[image]

The main class of the QPTL .NET library, that allows to calculate withholding/deduction taxes on payroll transactions of employers in the Canadian province of Quebec.

The following tables list the members exposed by QPTL.

Public Constructors

 | Name | Description
Public method | QPTL | Initializes a new instance of the QPTL class.
Top

Public Methods

 | Name | Description
Public method | calcDeductions | Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.
Public method | calcDeductionsResult | Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object. Additionally, a specific interim calculation result may be requested for audit purposes, identified by the resultID input parameter.
Public method | calculate | Obsolete. Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.
Public method | getDefE | Returns the value of the default Quebec TP-1015.3-V Total Claim (if no TP-1015.3-V on file) associated with the specified payroll date.
Public method | getEffDate | Returns a string representing the effective date of the library in the format YYYY-MM-DD (the date that calculations via the library become effective). The library cannot be used for payroll dates that are before this date.
Public method | getLastErrCode | Returns the code of the error/warning returned by the most recent call of a method of this class.
Public method | getMaxQPIP | Returns the maximum annual employee Quebec Parental Insurance Program (QPIP) deduction for the specified payroll date.
Public method | getMaxQPIPearnings | Returns the maximum annual employee QPIP insurable earnings for the specified payroll date.
Public method | getMaxQPIPemployer | Returns the maximum annual employer QPIP contribution for the specified payroll date.
Public method | getMaxQPP | Returns the maximum annual employee Quebec Pension Plan (QPP) deduction for the specified payroll date.
Public method | getMaxQPPearnings | Returns the maximum annual employee QPP pensionable earnings for the specified payroll date.
Public method | getTaxYear | Returns the taxation year the library has been released for. The library cannot be used for payroll dates that are after this year.
Public method | getTP1015_3V_ClaimRange | Returns the upper value of the TP1015_3V Claim range associated with the specified TP1015_3V claim code and payroll date.
Public method | getVersion | Returns the version identification string for the library.
Top

See Also

QPTL Class


QPTL Constructor

QPTL Constructor
[image]

Initializes a new instance of the QPTL class.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public QPTL()
C++
public:
QPTL() sealed
J#
public QPTL()
JScript
public function QPTL()

See Also

QPTL Class


Methods

QPTL Methods
[image]

Public Methods

 | Name | Description
Public method | calcDeductions | Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.
Public method | calcDeductionsResult | Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object. Additionally, a specific interim calculation result may be requested for audit purposes, identified by the resultID input parameter.
Public method | calculate | Obsolete. Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.
Public method | getDefE | Returns the value of the default Quebec TP-1015.3-V Total Claim (if no TP-1015.3-V on file) associated with the specified payroll date.
Public method | getEffDate | Returns a string representing the effective date of the library in the format YYYY-MM-DD (the date that calculations via the library become effective). The library cannot be used for payroll dates that are before this date.
Public method | getLastErrCode | Returns the code of the error/warning returned by the most recent call of a method of this class.
Public method | getMaxQPIP | Returns the maximum annual employee Quebec Parental Insurance Program (QPIP) deduction for the specified payroll date.
Public method | getMaxQPIPearnings | Returns the maximum annual employee QPIP insurable earnings for the specified payroll date.
Public method | getMaxQPIPemployer | Returns the maximum annual employer QPIP contribution for the specified payroll date.
Public method | getMaxQPP | Returns the maximum annual employee Quebec Pension Plan (QPP) deduction for the specified payroll date.
Public method | getMaxQPPearnings | Returns the maximum annual employee QPP pensionable earnings for the specified payroll date.
Public method | getTaxYear | Returns the taxation year the library has been released for. The library cannot be used for payroll dates that are after this year.
Public method | getTP1015_3V_ClaimRange | Returns the upper value of the TP1015_3V Claim range associated with the specified TP1015_3V claim code and payroll date.
Public method | getVersion | Returns the version identification string for the library.
Top

See Also

QPTL Class


calcDeductions Method

QPTL.calcDeductions Method
[image]

Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Sub calcDeductions( _
ByVal employeeData As EmployeeDataQC _
)
C#
public void calcDeductions(
EmployeeDataQC employeeData
)
C++
public:
void calcDeductions(
EmployeeDataQC employeeData
) sealed
J#
public void calcDeductions(
EmployeeDataQC employeeData
)
JScript
public function calcDeductions(
employeeData : EmployeeDataQC
)

Exceptions

Exception Type | Condition
ArgumentNullException | employeeData is a null reference.
ArgumentOutOfRangeException | A field/property of the specified EmployeeDataQC is not valid.

See Also

QPTL Class


calcDeductionsResult Method

QPTL.calcDeductionsResult Method
[image]

Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object. Additionally, a specific interim calculation result may be requested for audit purposes, identified by the resultID input parameter.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function calcDeductionsResult( _
ByVal employeeData As EmployeeDataQC, _
ByVal resultID As Integer _
) As Integer
C#
public int calcDeductionsResult(
EmployeeDataQC employeeData,
int resultID
)
C++
public:
int calcDeductionsResult(
EmployeeDataQC employeeData,
int resultID
) sealed
J#
public int calcDeductionsResult(
EmployeeDataQC employeeData,
int resultID
)
JScript
public function calcDeductionsResult(
employeeData : EmployeeDataQC,
resultID : int
) : int

Exceptions

Exception Type | Condition
ArgumentNullException | employeeData is a null reference.
ArgumentOutOfRangeException | A field/property of the specified EmployeeDataQC or resultID is not valid.

Remarks

Possible values of the resultID input parameter:
Value | Description
0 | I = estimated annual taxable income for Quebec
1 | H = the calculated Quebec deduction for employment income
2 | T = Quebec marginal tax rate based on estimated annual taxable income
3 | K = Quebec tax constant used in tax calculation
4 | Y = Calculated annual Quebec tax

See Also

QPTL Class


calculate Method

QPTL.calculate Method
[image]

NOTE: This method is now obsolete.

Use the calcDeductions method instead.

Calculates the required Quebec payroll tax deductions for the employee payroll input data contained in the specified EmployeeDataQC object, and stores the calculation results in the same EmployeeDataQC object.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Sub calculate( _
ByVal employeeData As EmployeeDataQC _
)
C#
public void calculate(
EmployeeDataQC employeeData
)
C++
public:
void calculate(
EmployeeDataQC employeeData
) sealed
J#
public void calculate(
EmployeeDataQC employeeData
)
JScript
public function calculate(
employeeData : EmployeeDataQC
)

Exceptions

Exception Type | Condition
ArgumentNullException | employeeData is a null reference.
ArgumentOutOfRangeException | A field/property of the specified EmployeeDataQC is not valid.

See Also

QPTL Class


getDefE Method

QPTL.getDefE Method
[image]

Returns the value of the default Quebec TP-1015.3-V Total Claim (if no TP-1015.3-V on file) associated with the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getDefE( _
ByVal payDate As String _
) As Integer
C#
public int getDefE(
string payDate
)
C++
public:
int getDefE(
String payDate
) sealed
J#
public int getDefE(
string payDate
)
JScript
public function getDefE(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The total claim in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getEffDate Method

QPTL.getEffDate Method
[image]

Returns a string representing the effective date of the library in the format YYYY-MM-DD (the date that calculations via the library become effective). The library cannot be used for payroll dates that are before this date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getEffDate() As String
C#
public string getEffDate()
C++
public:
String getEffDate() sealed
J#
public string getEffDate()
JScript
public function getEffDate() : String

See Also

QPTL Class


getLastErrCode Method

QPTL.getLastErrCode Method
[image]

Returns the code of the error/warning returned by the most recent call of a method of this class.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getLastErrCode() As Integer
C#
public int getLastErrCode()
C++
public:
int getLastErrCode() sealed
J#
public int getLastErrCode()
JScript
public function getLastErrCode() : int

Remarks

Error code values 0-10 are non-critical warnings only – i.e. the CPTL engine will complete all deduction calculations. Error code values > 10 are critical errors – CPTL will be unable to complete the deduction calculations or related functions.

Note
If a critical error occurs during execution of a method, the method throws an exception with the corresponding message.
Error code | Description
0 | Function and related calculations completed without errors.
1 | The current system date is past the expiry date for the current version of the CPTL library. Please ensure that you are using the correct version of CPTL to perform payroll deduction calculations.
4 | An invalid date was specified for the birthDate field of the EmployeeDataQC class. QPTL has not performed any CPP age eligibility calculations – the employee has been assumed to be CPP age eligible.
11 | An invalid claim code value was passed as a parameter to the getTP1015_3V_ClaimRange function. Valid claim code values are 0-10. Use claim code = 1 to claim the default Basic Federal Claim Amount.
23 | An invalid value was used for the annualPayPeriods field of the EmployeeDataQC class. See the annualPayPeriods field documentation for a list of valid annual Pay Period values, which range from 1-365 for non-commission income deduction calculations (0 is used ONLY for commission income calculations).
31 | An invalid value was specified for the calcType field of the EmployeeDataQC class. Valid values range from 1 to 5 and are defined in the CalculationType enum.
32 | An invalid value was used for the payPeriod field of the EmployeeDataQC class. Valid values range from 0 to a maximum value equal to the defined number of annual pay periods.
33 | An invalid value was used for the cntPP field of the EmployeeDataQC class. Valid values range from 0 to a maximum value equal to the defined number of annual pay periods minus the value of the current pay period, plus one.
34 | An invalid date was specified for the payDate field of the EmployeeDataQC class. Valid dates are in the format YYYY-MM-DD.
35 | An invalid value was specified for the retroPayPeriods of the EmployeeDataQC class. Valid values range from 1 to a maximum value equal to the defined number of annual pay periods.
36 | An invalid value was specified for the daysSincePrevCommPmt field of the EmployeeDataQC clas. Valid values range from 0-365.
42 | The specified payroll pay date is past the expiry date for the current version of the QPTL library. Payroll deduction calculations for the specified payroll date should be performed using an updated version of QPTL.
43 | The specified payroll pay date is prior to the effective date for the current version of the QPTL library. Payroll deduction calculations for the specified payroll pay date should be performed using a prior version of CPTL.
99 | The QPTL library was unable to load the appropriate version of the DLL corresponding to the pay date specified. Please check that all required DLL files are installed and accessible.
101 | An invalid UserID was used with the QPTL program. Please contact MET for QPTL license activation information.
102 | The trial period for a demo version of QPTL has expired. Please contact MET for QPTL license activation information.

See Also

QPTL Class


getMaxQPIP Method

QPTL.getMaxQPIP Method
[image]

Returns the maximum annual employee Quebec Parental Insurance Program (QPIP) deduction for the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getMaxQPIP( _
ByVal payDate As String _
) As Integer
C#
public int getMaxQPIP(
string payDate
)
C++
public:
int getMaxQPIP(
String payDate
) sealed
J#
public int getMaxQPIP(
string payDate
)
JScript
public function getMaxQPIP(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The maximum annual employee Quebec Parental Insurance Program (QPIP) deduction in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getMaxQPIPearnings Method

QPTL.getMaxQPIPearnings Method
[image]

Returns the maximum annual employee QPIP insurable earnings for the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getMaxQPIPearnings( _
ByVal payDate As String _
) As Integer
C#
public int getMaxQPIPearnings(
string payDate
)
C++
public:
int getMaxQPIPearnings(
String payDate
) sealed
J#
public int getMaxQPIPearnings(
string payDate
)
JScript
public function getMaxQPIPearnings(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The maximum annual employee QPIP insurable earnings in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getMaxQPIPemployer Method

QPTL.getMaxQPIPemployer Method
[image]

Returns the maximum annual employer QPIP contribution for the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getMaxQPIPemployer( _
ByVal payDate As String _
) As Integer
C#
public int getMaxQPIPemployer(
string payDate
)
C++
public:
int getMaxQPIPemployer(
String payDate
) sealed
J#
public int getMaxQPIPemployer(
string payDate
)
JScript
public function getMaxQPIPemployer(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The maximum annual employer QPIP contribution in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getMaxQPP Method

QPTL.getMaxQPP Method
[image]

Returns the maximum annual employee Quebec Pension Plan (QPP) deduction for the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getMaxQPP( _
ByVal payDate As String _
) As Integer
C#
public int getMaxQPP(
string payDate
)
C++
public:
int getMaxQPP(
String payDate
) sealed
J#
public int getMaxQPP(
string payDate
)
JScript
public function getMaxQPP(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The maximum annual employee Quebec Pension Plan (QPP) deduction in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getMaxQPPearnings Method

QPTL.getMaxQPPearnings Method
[image]

Returns the maximum annual employee QPP pensionable earnings for the specified payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getMaxQPPearnings( _
ByVal payDate As String _
) As Integer
C#
public int getMaxQPPearnings(
string payDate
)
C++
public:
int getMaxQPPearnings(
String payDate
) sealed
J#
public int getMaxQPPearnings(
string payDate
)
JScript
public function getMaxQPPearnings(
payDate : String
) : int

Parameters

payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The maximum annual employee QPP pensionable earnings in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The input parameter is a not empty string that does not specify a valid date in the format YYYY-MM-DD, or the specified date is PRIOR to the effective date (getEffDate) or AFTER the tax year (getTaxYear) of the library.

See Also

QPTL Class


getTaxYear Method

QPTL.getTaxYear Method
[image]

Returns the taxation year the library has been released for. The library cannot be used for payroll dates that are after this year.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getTaxYear() As Integer
C#
public int getTaxYear()
C++
public:
int getTaxYear() sealed
J#
public int getTaxYear()
JScript
public function getTaxYear() : int

See Also

QPTL Class


getTP1015_3V_ClaimRange Method

QPTL.getTP1015_3V_ClaimRange Method
[image]

Returns the upper value of the TP1015_3V Claim range associated with the specified TP1015_3V claim code and payroll date.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getTP1015_3V_ClaimRange( _
ByVal claimCode As Integer, _
ByVal payDate As String _
) As Integer
C#
public int getTP1015_3V_ClaimRange(
int claimCode,
string payDate
)
C++
public:
int getTP1015_3V_ClaimRange(
int claimCode,
String payDate
) sealed
J#
public int getTP1015_3V_ClaimRange(
int claimCode,
string payDate
)
JScript
public function getTP1015_3V_ClaimRange(
claimCode : int,
payDate : String
) : int

Parameters

claimCode
The TP1015_3V claim code. Valid values: 0-10.
payDate
The payroll date in the format YYYY-MM-DD. If the parameter value is a null reference or an empty string, the current date is used.

Return Value

The upper value of the TP1015_3V Claim range in whole cents.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | An input parameter is not valid.

See Also

QPTL Class


getVersion Method

QPTL.getVersion Method
[image]

Returns the version identification string for the library.

Namespace: met
Assembly: QPTL32 (in QPTL32.dll)

Syntax

Visual Basic (Declaration)
Public Function getVersion() As String
C#
public string getVersion()
C++
public:
String getVersion() sealed
J#
public string getVersion()
JScript
public function getVersion() : String

Remarks

The version string has the following format: QPTLW.yyyyX.Y.Z, where:
yyyy | calendar tax year
X | tax year update identifier (A = Jan 1; B = Jul 1)
Y | major release number (is used for major updates with added functionality)
Z | minor release number (is used for minor updates and bug fixes)

See Also

QPTL Class


met Hierarchy

met Hierarchy
System.Object
met.EmployeeDataQC
met.QPTL
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
met.CalculationType

See Also

met Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Middle Earth Technologies Ltd.


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace